Configuring Interfaces

This section provides information about configuration of the front panel interfaces of the Cisco Nexus 3550-T Programmable Switch Platform.

You can access the interface related functions through the interface command. Without the config modifier, these commands are limited to showing the current interface status. With the config modifier it is possible to change settings on the interface.

It is possible to enter all commands shown in this section either on a single line or from within the interface modal state. To enter the modal state for a given interface, enter the following command:

admin@NX-3550-T# config interface ethernet1
admin@NX-3550-T(config-if-et1)#

When you are in the interface modal state, it is possible to omit the config interface ethernet1 prefix from commands.

You can use the shortened command int in place of interface end et in place of ethernet:

admin@NX-3550-T# config int et1
admin@NX-3550-T(config-if-et1)#

Disable an Interface

To disable a specific interface via CLI, use the following command:

admin@NX-3550-T# config interface et4 shutdown

The above command disables the interface et4. To verify that et4 is disabled, use the following command:

admin@NX-3550-T# config sh int et4
Interface ethernet4 is disabled
Speed is 10000 Mbps

Enable an Interface

To enable a specific interface via CLI, use the 'no' form of the shutdown command:

admin@NX-3550-T# config interface et4 no shutdown

The above command enables the et4 interface.

To verify that et4 is enabled, use the following command.

admin@NX-3550-T# config sh int et4
Interface ethernet4 is up
Speed is 10000 Mbps

Assign IP Address

To assign the IPv4 addresses to specific interfaces via CLI, use the following command:

admin@NX-3550-T# config interface et4 ip address 110.110.110.110/24

To verify the assigned address use the show command as follows:

admin@NX-3550-T# config sh ru int et4
interface ethernet4
speed 10000
ip address 110.110.110.110/24
ip pim rp 192.168.10.2 224.0.0.0/4
hostname NX-3550-T
ip name-server 64.104.200.248
vrf context management
ip route 0.0.0.0/0 10.67.149.1

Add a Description to an Interface:

For easy identification about the role of an interface on Nexus 3550-T, you can add a description to that interfaces.

For example, say interface et4 is receiving multicast data from group MG1. To assign a description to the specific interface via CLI, use the following command:

admin@NX-3550-T# config interface et4 description "multicast-group-MG1"

Verify the assigned address by using the show command as follows.

admin@NX-3550-T# config sh int et4
interface ethernet4 enabled
Description: multicast-group-MG1
speed 10000

Assign Interface Speed

To assign a speed to specific interfaces via CLI, use the following command:

admin@NX-3550-T# config interface et4 speed 10000

Note

Currently, the only supported speed is 10000 Mbps.

Access Interface Details

Detailed interface statistics are available on all interfaces. You can access the statistics by using the show command. For example, to show detailed statistics on interface ethernet1, use the following command:

admin@NX-3550-T# show interface ethernet1
Interface ethernet1 is up
Pluggable transceiver detected
Hardware address is 46:cc:39:5a:43:0, MTU 1500 bytes
Speed is 10000 Mbps
Link flap counter is 0
Rx counters
  1875 input frames
  0 unicast frames  1875 multicast frames  0 broadcast frames
  0 error frames
Tx counters
  10397 output frames
  0 unicast frames  8283 multicast frames  2114 broadcast frames
  0 error frames

Obtain an Interface Overview

In addition to the detailed output available for all interfaces, you can obtain an overview by using the generic show interface brief command without specifying an interface. This command shows a summary of all interfaces in the device along with its current status.

admin@NX-3550-T# show interface brief
Interface Status Transceiver Speed
--------- ------ ----------- -----
et1       up      SFP         10000
et2       up      SFP         10000
et3       down    SFP         10000
et4       up      SFP         10000
et5       up      SFP         10000
et6       up      SFP         10000
et7       up      SFP         10000
et8       up      SFP         10000
et9       down    --          10000
...

Configure Multiple Interfaces

Given that the Nexus 3550-T can have as many as 48 interfaces, an extensive multi-interface addressing syntax has been added to the CLI. The following two types of selection methods are available:

  • Range selectors
  • Unix style command line wildcards
Select a Range of Interfaces

The interface selection syntax supports selecting a range of interfaces delineated by the - character.

admin@NX-3550-T# show interface ethernet1-4 brief
Interface Status Transceiver Speed
--------- ------ ----------- -----
et1       up      SFP         10000
et2       up      SFP         10000
et3       down    SFP         10000
et4       up      SFP         10000

You can select a specific range of interfaces by using the , character.

admin@NX-3550-T# show interface ethernet1,3,5 brief
Interface Status Transceiver Speed
--------- ------ ----------- -----
et1       up      SFP         10000
et3       down    SFP         10000
et5       up      SFP         10000
Combine Connector/Interface Range Selectors

You can combine range selectors to select interfaces across multiple physical connectors.

admin@NX-3550-T# show interface ethernet1-3,5 brief
Interface Status Transceiver Speed
--------- ------ ----------- -----
et1       up      SFP         10000
et2       up      SFP         10000
et3       down    SFP         10000
et5       up      SFP         10000

This page was last updated on Mar-23-2021.