Configuration Management

Show and Save the Current Configuration

The configuration of the Cisco Nexus 3550-T Programmable Switch Platform is described by a running-config, which contains all settings that are currently in effect on the device.

admin@NX-3550-T# show running-config
interface ethernet1
  speed 10000
interface ethernet2
  speed 10000
switchport mode access
switchport access vlan 10
………
interface ethernet48
  speed 10000
interface vlan1
interface vlan10
  ip address 10.0.0.1/24
ip pim
ip igmp version 3
router bgp 123
  neighbor 192.168.10.2 remote-as 456
ip pim rp 192.168.10.2 224.0.0.0/4
spanning-tree priority 32768
username admin password (hidden)
hostname NX-3550-T
interface management1
  no shutdown
  ip address 192.168.220.10/24
interface management2
  no shutdown
vrf context management
  ip route 0.0.0.0/0 192.168.220.254
clock timezone UTC
aaa authentication login default local
aaa authorization exec default none

Given the considerable number of interfaces available in the Nexus 3550-T, the full output of show running-config may be more verbose than you require. You can examine the configuration of a particular interface, for example:

admin@NX-3550-T# show running-config interface ethernet1
interface ethernet1
  speed 10000
  switchport mode access
  switchport access vlan 10
ip pim rp 192.168.10.2 224.0.0.0/4
hostname NX-3550-T
ip name-server 192.168.220.248
vrf context management
  ip route 0.0.0.0/0 192.168.220.254

To show the configuration of a number of interfaces, combine this command with range selectors. For more details, see Configuring interfaces.

admin@NX-3550-T# show running-config interface ethernet1-3
interface ethernet1
  speed 10000
interface ethernet2
  speed 10000
  switchport mode access
  switchport access vlan 10
interface ethernet3
  speed 10000
  switchport mode access
  switchport access vlan 10
ip pim rp 192.168.10.2 224.0.0.0/4
hostname NX-3550-T
ip name-server 192.168.220.248
vrf context management
  ip route 0.0.0.0/0 192.168.220.254

As mentioned in the Command line interface topic, for improved readability, you can redirect the output of these commands into Unix utilities such as grep and less.

admin@NX-3550-T# show running-config | grep management -A 1
interface management1
  no shutdown
--
interface management2
  no shutdown
vrf context management
  ip route 0.0.0.0/0 192.168.220.254

To make the running-config persistent across reboots of the device, you must save it to the startup-config. To save the running-config to the startup-config, use the copy command.

admin@NX-3550-T# configure copy running-config startup-config
Saved running config to startup config

Any setting in the startup-config is applied to the device at the time of booting.

Create Custom Configurations

You can create custom configurations by copying existing configurations. You can use the running-config and startup-config to accomplish this:

admin@NX-3550-T# config copy running-config myconfig
Saved running config to "myconfig"

Then, apply these configurations to the running-config or startup-config.

Erase Configurations

Along with custom configurations that you created, you can erase the startup-config by using the erase startup-config command. This command reverts the Nexus 3550-T's power-up settings to the factory default settings.

Depending on how much of the configuration you want to reset, you can erase various elements of the running-config.

admin@NX-3550-T(config)# erase running-config
Usage: erase startup-config
       erase running-config [all] [management] [data-plane]
Erase configuration files
  • all resets the running-config to the factory default settings, potentially rendering the device inaccessible from the current connection.

  • management resets only those parts of the running- config related to the management of the device, not the high-speed interface configuration. For example, hostname management address, passwords, logging etc. are all covered in this reset group. This option could potentially render the device inaccessible from the current connection.

  • data-plane resets all interface configurations.

Take a Backup of the Configuration

The startup-config is stored within the Nexus 3550-T as a number of .json files, in the /mnt/persist/config/ directory. You can retrieve these files from the device by using scp or sftp for backup purposes, and put them back onto the device if necessary.

To retrieve the config files via scp, run the following command:

$ scp admin@NX-3550-T:/mnt/persist/config/*.json ./

To retrieve these files via sftp, run the following command:

$ sftp admin@NX-3550-T
admin@NX-3550-T's password:
Connected to admin@NX-3550-T.
sftp> get /mnt/persist/config/*.json

This page was last updated on Mar-23-2021.